1 (edited by N350Z 2012-09-13 19:18:53)

Topic: JPEG problem

Dear support team,

Some time ago I found your "image analyzer" on the internet and the functions are great. Every now and then I would like to know the average value of (large) 8 bits grey images. Till now this was possible with my TIFF's and JPEG's.

Last week I installed the IA on another PC (Windows 7 / 64 bit / maybe not relevant but I installed JAVA 7 version 7).

The problem:

When I load TIFF images, I can see that 8 bits of grey values are present in the image.
When I load JPEG's (which are OK in same software on the older PC), there are only 16 grey values present in the image. This is seen when zooming in the image (limited amount of grey values remain) but also in the color mapper. On following grey values, the amounts of pixels are displayed: 0-17-34-51-68-85-102-119-136-153-170-187-204-221-238-255. Same JPEG's have all grey values in other applications. It looks like IA changes the 8 bits to 4bits while i did not select any filtering.

Any suggestion for me ? Or what should I check on this other PC ?

Kind regards,

Ruud - Tilburg - Netherlands

2

Re: JPEG problem

Strange... Does this happen with all jpegs or just some? What about color images?

Michael Vinther

> software developer <

Re: JPEG problem

Hello,

Now this problem also happened on another PC; when I open the 8 bits grey image in IA, again the grey values look rounded (when zooming in till pixel level, I see a kind of pepper and salt pattern). But same image in Windows Photo Viewer looks OK. New finding: in paint same thing happens as in IA (so NOK) so it is not a IA problem only. With colour JPG's it looks OK but maybe it is more difficult to see. Do you have any suggestion for me ? Maybe I can send screen shots to you to explain the problem in more detail ?

Kind regards,

Ruud

4

Re: JPEG problem

Very interesting, I can also reproduce it. I will try to investigate...

Michael Vinther

> software developer <

5

Re: JPEG problem

This should now be fixed in the latest beta version which you can download from the forum

Michael Vinther

> software developer <

Re: JPEG problem

In the beta i got a error that FastMM_FullDebugMode.dll could not be found.

Spam deleted 2013: 54,  2014: 11,  2015: 3,  2016: 107

7

Re: JPEG problem

Should be fixed now

Michael Vinther

> software developer <

Re: JPEG problem

Yes, beta 1.34.8 starts now smile

Spam deleted 2013: 54,  2014: 11,  2015: 3,  2016: 107

Re: JPEG problem

i was just puzzled by this, now beta 1.34.8 works.